看股吧 www.gpsupdateshelp.com [今日大盤指數 歐美全球股市行情 股票公式查詢網站] 手機APP下載 | 手機訪問 | 加入收藏 | 保存到桌面
              看股吧
              看股吧股票網-今日大盤指數 歐美全球股市行情 股票公式查詢網站
              股票查詢: 行情分析 DDX指標 走勢點評 股票公告 大事 主力持倉 股權質押 分紅 大小非 十大股東 股本結構 高管持股 研報 高管 主營 龍虎榜 股吧
              當前位置: 看股吧 > 股票公式 > 通達信公式
              股票公式搜索:

              通達信波段四種背離指標公式

              2021/7/22 18:43:31

              SJ:=1;
              嚴重超買:100*SJ,COLORRED,DOTLINE;
              超買:80,COLORRED,DOTLINE;
              超賣:20,COLOR00FF00,DOTLINE;
              嚴重超賣:0*SJ,COLOR00FF00,DOTLINE;
              MACD頂背:0,COLOR00FF00;
              MACD底背:0,COLORRED;
              KDJ頂背:0,COLORFFCC66;
              KDJ底背:0,COLORFF00FF;
              RSI頂背:0,COLORFFFFFF;
              RSI底背:0,COLORYELLOW;
              DMI頂背:0,COLORBLUE;
              DMI底背:0,COLOR0099FF;
              TRR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
              HD := HIGH-REF(HIGH,1);
              LD := REF(LOW,1)-LOW;
              PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
              MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
              PDI:= PDM*100/TRR;
              MDI:= MDM*100/TRR;
              A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1))*SJ;
              B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9))*SJ;
              A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
              B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3))*SJ;
              A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
              B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24))*SJ;
              C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));
              D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9))*SJ;
              C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
              D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3))*SJ;
              C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
              D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24))*SJ;
              C4:=BARSLAST(REF(CROSS(MDI,PDI),1));
              D4:=REF(C,C+1)<C AND REF(MDI,C4+1)>MDI AND CROSS(MDI,PDI);
              A4:=BARSLAST(REF(CROSS(PDI,MDI),1));
              B4:=REF(C,A4+1)>C AND REF(PDI,A4+1)<PDI AND CROSS(PDI,MDI);
              DRAWTEXT(B4>0,5,'DMI底背'),COLOR0099FF;
              DRAWTEXT(D4>0,95,'DMI頂背'),COLORBLUE;
              DRAWTEXT(B1>0,15,'MACD底背'),COLORRED;
              DRAWTEXT(B2>0,10,'KDJ底背')*SJ,COLORFF00FF;
              DRAWTEXT(B3>0,18,'RSI底背')*SJ,COLORYELLOW;
              DRAWTEXT(D1>0,85,'MACD頂背')*SJ,COLOR00FF00;
              DRAWTEXT(D2>0,90,'KDJ頂背')*SJ,COLORFFCC66;
              DRAWTEXT(D3>0,96,'RSI頂背')*SJ,COLORFFFFFF;
              STICKLINE(B1>0,20,0,0,0),COLORRED;
              STICKLINE(B2>0,20,0,0,0),COLORFF00FF;
              STICKLINE(B3>0,20,0,0,0),COLORYELLOW;
              STICKLINE(D1>0,80,100,0,0),COLOR00FF00;
              STICKLINE(D2>0,100,80,0,0),COLORFFCC66;
              STICKLINE(D3>0,100,80,0,0),COLORWHITE;
              STICKLINE(B4>0,20,0,0,0),COLOR0099FF;
              STICKLINE(D4>0,100,80,0,0),COLORBLUE;
              VAR188:=((CLOSE - LLV(LOW,34))/(HHV(HIGH,34) - LLV(LOW,34)))*(100);
              VAR288:=REVERSE(VAR188);
              VAR388:=SMA(VAR188,9,1);
              K88:=SMA(VAR388,3,1)*SJ;
              D88:=SMA(K88,3,1)*SJ;
              STICKLINE((K88 >= D88),K88,D88,1,0),COLOR0000FF;
              STICKLINE((K88 <= D88),K88,D88,1,0),COLOR00FF00;


              看股 吧公式 www.kangub a.com

              [源碼翻譯]通達信公式動態翻譯顯示
              SJ賦值:1
              輸出嚴重超買:100*SJ,畫紅色,DOTLINE
              輸出超買:80,畫紅色,DOTLINE
              輸出超賣:20,COLOR00FF00,DOTLINE
              輸出嚴重超賣:0*SJ,COLOR00FF00,DOTLINE
              輸出MACD頂背:0,COLOR00FF00
              輸出MACD底背:0,畫紅色
              輸出KDJ頂背:0,COLORFFCC66
              輸出KDJ底背:0,COLORFF00FF
              輸出RSI頂背:0,COLORFFFFFF
              輸出RSI底背:0,畫黃色
              輸出DMI頂背:0,畫藍色
              輸出DMI底背:0,COLOR0099FF
              賦值: 最高價-最低價和最高價-1日前的收盤價的絕對值的較大值和最低價-1日前的收盤價的絕對值的較大值的14日累和
              賦值: 最高價-1日前的最高價
              賦值: 1日前的最低價-最低價
              PDM賦值: 如果HD>0ANDHD>LD,返回HD,否則返回0的14日累和
              MDM賦值: 如果LD>0ANDLD>HD,返回LD,否則返回0的14日累和
              PDI賦值: PDM*100/TRR
              MDI賦值: MDM*100/TRR
              A1賦值:上次1日前的"平滑異同平均的DIF"(12,26,9)上穿"平滑異同平均的DEA"(12,26,9)距今天數*SJ
              B1賦值:A1+1日前的收盤價>收盤價 AND A1+1日前的"平滑異同平均的DIF"(12,26,9)<"平滑異同平均的DIF"(12,26,9) AND "平滑異同平均的DIF"(12,26,9)上穿"平滑異同平均的DEA"(12,26,9)*SJ
              A2賦值:上次1日前的"KDJ的K"(9,3,3)上穿"KDJ的D"(9,3,3)距今天數
              B2賦值:A2+1日前的收盤價>收盤價 AND A2+1日前的"KDJ的K"(9,3,3)<"KDJ的K"(9,3,3) AND "KDJ的K"(9,3,3)上穿"KDJ的D"(9,3,3)*SJ
              A3賦值:上次1日前的"RSI的RSI1"(6,12,24)上穿"RSI的RSI2"(6,12,24)距今天數
              B3賦值:A3+1日前的收盤價>收盤價 AND A3+1日前的"RSI的RSI1"(6,12,24)<"RSI的RSI1"(6,12,24) AND "RSI的RSI1"(6,12,24)上穿"RSI的RSI2"(6,12,24)*SJ
              C1賦值:上次1日前的"平滑異同平均的DEA"(12,26,9)上穿"平滑異同平均的DIF"(12,26,9)距今天數
              D1賦值:C1+1日前的收盤價<收盤價 AND C1+1日前的"平滑異同平均的DIF"(12,26,9)>"平滑異同平均的DIF"(12,26,9) AND "平滑異同平均的DEA"(12,26,9)上穿"平滑異同平均的DIF"(12,26,9)*SJ
              C2賦值:上次1日前的"KDJ的D"(9,3,3)上穿"KDJ的K"(9,3,3)距今天數
              D2賦值:C2+1日前的收盤價<收盤價 AND C2+1日前的"KDJ的K"(9,3,3)>"KDJ的K"(9,3,3) AND "KDJ的D"(9,3,3)上穿"KDJ的K"(9,3,3)*SJ
              C3賦值:上次1日前的"RSI的RSI2"(6,12,24)上穿"RSI的RSI1"(6,12,24)距今天數
              D3賦值:C3+1日前的收盤價<收盤價 AND C3+1日前的"RSI的RSI1"(6,12,24)>"RSI的RSI1"(6,12,24) AND "RSI的RSI2"(6,12,24)上穿"RSI的RSI1"(6,12,24)*SJ
              C4賦值:上次1日前的MDI上穿PDI距今天數
              D4賦值:收盤價+1日前的收盤價<收盤價 AND C4+1日前的MDI>MDI AND MDI上穿PDI
              A4賦值:上次1日前的PDI上穿MDI距今天數
              B4賦值:A4+1日前的收盤價>收盤價 AND A4+1日前的PDI<PDI AND PDI上穿MDI
              當滿足條件B4>0時,在5位置書寫文字,COLOR0099FF
              當滿足條件D4>0時,在95位置書寫文字,畫藍色
              當滿足條件B1>0時,在15位置書寫文字,畫紅色
              當滿足條件B2>0時,在10位置書寫文字*SJ,COLORFF00FF
              當滿足條件B3>0時,在18位置書寫文字*SJ,畫黃色
              當滿足條件D1>0時,在85位置書寫文字*SJ,COLOR00FF00
              當滿足條件D2>0時,在90位置書寫文字*SJ,COLORFFCC66
              當滿足條件D3>0時,在96位置書寫文字*SJ,COLORFFFFFF
              當滿足條件B1>0時,在20和0位置之間畫柱狀線,寬度為0,0不為0則畫空心柱.,畫紅色
              當滿足條件B2>0時,在20和0位置之間畫柱狀線,寬度為0,0不為0則畫空心柱.,COLORFF00FF
              當滿足條件B3>0時,在20和0位置之間畫柱狀線,寬度為0,0不為0則畫空心柱.,畫黃色
              當滿足條件D1>0時,在80和100位置之間畫柱狀線,寬度為0,0不為0則畫空心柱.,COLOR00FF00
              當滿足條件D2>0時,在100和80位置之間畫柱狀線,寬度為0,0不為0則畫空心柱.,COLORFFCC66
              當滿足條件D3>0時,在100和80位置之間畫柱狀線,寬度為0,0不為0則畫空心柱.,畫白色
              當滿足條件B4>0時,在20和0位置之間畫柱狀線,寬度為0,0不為0則畫空心柱.,COLOR0099FF
              當滿足條件D4>0時,在100和80位置之間畫柱狀線,寬度為0,0不為0則畫空心柱.,畫藍色
              VAR188賦值:((收盤價 - 34日內最低價的最低值)/(34日內最高價的最高值 - 34日內最低價的最低值))*(100)
              VAR288賦值:VAR188的相反數
              VAR388賦值:VAR188的9日[1日權重]移動平均
              K88賦值:VAR388的3日[1日權重]移動平均*SJ
              D88賦值:K88的3日[1日權重]移動平均*SJ
              當滿足條件(K88>=D88)時,在K88和D88位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLOR0000FF
              當滿足條件(K88<=D88)時,在K88和D88位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLOR00FF00

              其它股票公式列表
              看股吧查股導航:個股行情分析查詢 股票DDX指標查詢 走勢點評 股票公告查詢 大事提醒 股權質押查詢 股票分紅查詢 解禁查詢 高管持股 高管查詢
              東南網架 002135+7.19% 公告 DDX在線 走勢點評 限售解禁 高管 股權質押
              華陽集團 002906+7.11% 公告 DDX在線 走勢點評 限售解禁 高管 股權質押
              賢豐控股 002141+7.08% 公告 DDX在線 走勢點評 限售解禁 高管 股權質押
              晶盛機電 300316+7.01% 公告 DDX在線 走勢點評 限售解禁 高管 股權質押
              南方軸承 002553+6.92% 公告 DDX在線 走勢點評 限售解禁 高管 股權質押
              中國電建 601669+6.90% 公告 DDX在線 走勢點評 限售解禁 高管 股權質押
              國城礦業 000688+6.89% 公告 DDX在線 走勢點評 限售解禁 高管 股權質押
              華陽股份 600348+6.89% 公告 DDX在線 走勢點評 限售解禁 高管 股權質押
              通業科技 300960+6.77% 公告 DDX在線 走勢點評 限售解禁 高管 股權質押
              彤程新材 603650+6.74% 公告 DDX在線 走勢點評 限售解禁 高管 股權質押
              看股網力求但不保證數據的完全準確,不對因網站全部內容或部分內容而引致的盈虧承擔任何責任,本站所有內容僅供參考。
              本站不提供任何股票服務,站內廣告不代表看股吧的觀點,由此引起的一切法律責任均與本站無關,請股民自行識別判斷,謹慎投資,預防上當受騙!
              聯系我們:nlfen9@hotmail.com
              手機版(手機訪問當前頁面) | 手機APP下載 | 電腦端(適合電腦或大屏用戶)
              少妇乱公伦